Problem in crowded airports

Recently i have had some rendering problem in crowded airports. And i have been ghosted because of taxiing (cutting) into grass because i couldn’t see.
I also have this problem when I’m landing but i can handle that with my localizer.
Is there anything i can do to solve this problem?

1 Like

Have you tried lowering your settings?

Don’t go to crowded airports 😂


What do you mean by this? Can you send us a screenshot on what exactly did you just saw? I am missing some information.

Yes i did that but it wasn’t fixed.

Haha. so why do i play online then😂😂

Bruh if ur taxiing on the grass on expert server ur bound to get ghosted

I have this problem quite frequently actually (that why I fly on training a lot). What I do is check the map and see if they are actually still in front of you

Yes but i cannot see because of this problem.
So thats why Im not flying on expert server anymore and trying to fix this asap.

This can’t be happening. IF has many ways to allow you to see what you’re doing. Watch where you’re going.

That is a not very clear description of what exactly the problem is.
I suspect you mean you don’t know how to transition from Approach to Tower after intercepting the localiser. We have great tutorials for this on this forum.

While you’re here on this forum, please make sure you stick around and check out this amazing place. The #tutorials section you will find most educational.

1 Like

Yes I actually do that while landing but you cannot see the taxiway on map!

No, but the problem sounds like this occurs while your waiting for takeoff, and if that’s the case, you can see aircraft infront of you. If it’s landing, that’s your fault cause ATC would ask you to go around. In the HUD view, have the map zoomed in really far and you can see your location compared to other aircraft closely

Actually the whole screen will either go white or blue and I cannot see anymore. This also happens when I change my cameras.

Do you mind taking a photo of this in a replay where this occurred?

This sounds like an issue. As requested, we need to see this happening via video or screenshots. If this is a problem, this needs to be raised with #support

1 Like

It seems like his problem is that he might have his settings on the lowest and time set to noon, what happens is that the taxiways are very white with those circumstances and very hard to see, but the grass still differs from the taxiway so please elaborate a bit more.

Go to live and set planes shown to low. This reduces the amount of planes your device has to render.

Which view do you use when you taxi? If you got less powerful device use back camera to taxi, don’t have to pretend realism and get ghosted. Do what works best for you.

These are some screenshots of my problem

I’ve tried multiple cameras but it will not work.