Planes will not pull up.

Hello community. So, lately I have been having room weird problems with my aircraft. The planes just won’t get off the ground. I’ve set my flaps and calibrated my device but nothing has worked. This first happened a few minutes ago with the K-10. I was on a short runway so I thought maybe I just didn’t have enough runway. So then, I wanted to go and try the new Auto Pilot and refueling with the F-22. I started in Atlantic City. I started to take offhand again I couldn’t get off the ground even at 250kts with flaps and a calibrated device. After that I restarted my device and it still didn’t work. Has this happened to anyone else? My device is a iPad Air 2.
Thanks for your help in advance,
Watts

Maybe try a delete and reinstall

1 Like

Steps to try:

  1. Restart your device
  2. Reinstall the app
  3. Update your iOS
2 Likes

What did you set your trim to?

My IOS is up to date and I tried restarting the app. I’ll try again though…

When viewed from the exterior of the aircraft or looking at the yoke. Do the elevators move when moving the device?

If no go into setting and reset the defaults on the controls.

After three restarts it seems to work. Thanks everyone!

Glad you got it working! Let us know if any other issues occur.

1 Like