Planes not showing in game

The ingame map is not showing any planes, and I am not being shown on liveflight. My connection to the server is green. I cannot really restart the game as I am in flight, although if I have this issue on approach I might back out in case I get ghosted. I am connected to WiFi with a strong connection.
My device is an iPad Pro. Thanks!


Could you please try turning off the WiFi in your phone’s settings until you have a red mark next to the live-server-connection and then turn WiFi back on?

If it doesn’t work the first time, do it a second time.


Just making sure, are you on the correct server? :)


Yes, for sure. I am on expert.

I meant to say there is no difference. There is a green check even when WiFi is off. I have tried this three times…

Are your device cellular capable?
How long did when you turned connection off? It can take up to 10-15 seconds, if not even more before the checkmark turns red.

1 Like

I am on an iPad, it is WiFi only. I waited around 10 seconds. I will try for 20 now.

Tried for 30 now, still no change. Shall I go longer?
Edit: tried second time for longer, still green.

That’s odd.
It seems like your app is stuck in some connectivity state and won’t realize it’s disconnected…

There’s not much that can be done I’m afraid…

1 Like

Shall I shut down the app (sadly ending my flight rip) and just spawn in randomly and see?

That will most likely solve it. Restarting the iPad prior to spawning in is a good idea.

I did restart my iPad, I do before every flight.

Not saying you didn’t.
Just meant it could be a good idea this time as the app seemed to be stuck in a connection state :)

1 Like

I’ll just continue my flight from the nearest airport. Thanks for your help! This can be closed at your discretion :)