Planes Not Loading - Global

I am currently using an iPad Air 2 (iOS 11.) This is global specific, as it did not happen before global. I tried reinstalling the app, and tried it on a different device (iPad Pro) but it still doesn’t work.
7F693ACB-DDDC-4D85-A9B2-BC9B01CAC4B1
Screenshot of settings:
6E640FC4-7384-4DDD-91F3-53091DA0C043

It doesn’t load them in the same way prior to global. It takes a while for the aircraft to load in. It also maybe spotty.

Edit: didn’t see the squares

1 Like

Yes, there are meant to be other planes around me.

I edited I’ve noticed high graphics settings will also take longer to load them in then medium.

1 Like

Ill try reducing the graphics settings.

It only shows installed planes - is that a feature

You know I can’t answer that one. I don’t think so though. @Tyler_Shelton can answer it for us.

I don’t have an answer for that one either. We have changed the way aircraft are rendered and you’ll notice that other aircraft now share your own aircraft’s quality but I don’t know the specifics behind that. Sorry, guys!

4 Likes

I fixed the problem: for future reference:
The game only displays planes that you have downloaded (I think) on the device. So when I downloaded all the planes, I could see all of the planes online.

2 Likes