Paid for subscription shows no subscription.

I paid for subscription and it doesn’t show in my app. Says buy subscription. No subscription found. What the hell


Have you logged in with the same credentials?

Please file a proper support request in the correct support request format .

Have you tried restarting your device?

Thanks for contacting support!

Can you please verify two things before we continue;

  • That you are trying to access the subscription with the same account that you bought it with

  • That you have tried the “I already have a subscription”

Kind Regards,

1 Like

Try restarting your device, Delete and re-install IF, and log out and back into what ever account you are using

I have done all things you have said. Kindly refund or make it work.

No need for aggression, if you have an Android Device, please go through the Google play store and contact them there for a refund.
If you’re on iOS, go on the App Store and contact Apple for a refund.

Also, I’m not very familiar with Android, so you’d have to somehow find where “Restore Purchases” is as well. On iOS, theirs a button with restore purchases.

1 Like

No aggression man. Any one with a idea to make it work ?

1 Like

Please send us an email at and please provide the following:

  • Current display name and callsign
  • Device being used
  • Purchase Receipt (showing order number # beginning with “GPA”)

We appreciate your patience and look forward to resolving this!

Kind Regards,