Objects not rendering

Hey, I’ve been having some difficulties with 3D objects rendering.

I’ve attempted to perform KSFO - PHOG twice now. However, upon reaching the airport. It doesn’t load at all. The runway doesn’t load, the taxiways or gates don’t load, the 3D buildings won’t load, and not even the runway lights load in. I’ve tried a few different solutions such as flying away from the airport to reload it, messing around with the graphics settings, and even diverting to another airport, which also wouldn’t load in. I’ve also noticed other players won’t load either. It’s as if the rendering engine is breaking on my end. I’ve even exited the flight and loaded in again, to no prevail. I have had to do a full app restart in order to fix it, and it’s very inconvenient, as twice now, I’ve had to bail out of a flight because nothing is loading in except the terrain.

For reference this is what I see.


This is after freshly loading in after bailing the flight.

Could this be potentially caused by lack of device storage?

Does anyone know any fixes?

Hello there Canuck

There is a fix to this issue. If you go to

Settings > Graphics > 3D Object Density > Switch it to low and then switch it back to your current setting.

1 Like

I wish this did work… I’ve tried it multiple times to no prevail. 😔

1 Like

Have you tried the clear scenery cache?

1 Like

Yes. I’ve tried everything to do with the settings, but nothing works except a full restart, unfortunately. 😔

And what’s your storage currently on your device?

1 Like

This is a separate issue I’m running into, but I’m beginning to think the two are related. My device storage is sitting at 23/30 GB. I have more than enough storage available, yet my iPad is sending me device storage FULL notifications.

I’m not sure what to do.

I think that’s the issue if you’re IPad is sending you that notification

1 Like

I’ll see if I can find a fix to that then. I’m not sure why it’s giving me those notifications…

1 Like

Yeah, that is weird though

1 Like

That message that sends you full space is the iCloud, it has nothing to do with the device’s storage.

1 Like

Just going to give the original issue a bump as I haven’t got a solid answer what’s causing this.

Any have any idea what’s causing his and how to fix it?

Giving this a bump.

Did the flight for a third time now, and so far it seems with the same results from above. This is extremely frustrating and I don’t know what to do at this point.

I’ve tried changing 3D Object rendering settings, I’ve updated my iPad, I’ve cleared cache and freed up space, and I’m still having this issue. Does anyone have a solution?

Side note: As for the storage issue, both iTunes and my iPad say I have 10 gb of free space left, so my device is not out of storage, it’s just a software glitch.

You ain’t the only one I made a thread for this airports not loading 😖 it’s very frustrating

1 Like

This is the third time I’ve done this medium haul, and so far every time this has happened to me. Very frustrating! :(

1 Like

Happens me twice very close to jfk airport hopefully will go well I have a feeling it won’t happened me twice flying to EHAM twice 😩

2 Likes

I’m currently approach TOD for PHOG, so I went to check the “ATC” cam to see if it would load, and it doesn’t appear so.

I really wish there could be a quick fix to this.

1 Like

I know about 250nm out from jfk it better load or not I’d go mental.

1 Like

Yeah, this is exactly what’s happening to me. The airports won’t load at all. I’m also finding other players aren’t loading either, and they just appear as white boxes.