Not Showing “Use Network Device”

I’ve just gotten a joystick for IF, I found that there is a software to connect it (LiveFlight Connect), i downloaded it and I have tried EVERYTHING but it doesn’t seem to say Use Network Device on IF, or when I go into a Flight it doesn’t show me my Speed, V/S etc. I have tried speaking to the LiveFlight developers but they haven’t been much help (not saying that haven’t tried very hard). Anyone else with this issue

1 Like

Hey there! Welcome to the community!

Some key notes are that you can search topics regarding this same issue in the search tab! 😁 nevertheless, here is one that may help!

1 Like

No it should not. It’s not an issue with the app, but with the connectivity to LiveFlight.


Sorry bout’ that @schyllberg

1 Like

@schyllberg I’m still awaiting his response to see if it worked. If it doesn’t, maybe you can help him. 😁

May I ask, are you on the same network?

Have you ensured you have the setting enabled on IF to allow LiveFlight?

1 Like

… you use a usb, not a wifi connection

But you need to be connected on the same network so it transfers the data it’s needs to.

1 Like

Yes, I have.

Yes, I am.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.