Not compatible with Samsung S8?

Im running the latest version of Android on my samsung galaxy s8 but it says that the app is not compatible with S8.
Is S8 supported?

1 Like

It is supported, check out the minimum requirements: