Not allowing me to get subscription

When I click on the inflight live thing it tells me I don’t have a subscription which is true then I click on get a subscription but I can click on live or live+ to purchase it. As you can see belowimage

Can you give us your current device and operating system?


My suggestion for you is to reinstall the app and restart your device. And are you sure you are connected to the internet? The “error” thing usually pops up when you are not connected with the internet. Hope this help ;0


Click on “I already
have a subscription”.


Go to the infinite flight website, and subscribe there click Here for the site.
It occasionally doesn’t work in app this will get it to work for you. Once you have subscribed there then you can click, I already have a subscription


If both I already have a subscription and the website doesn’t work, contact @Tyler_Shelton or @Mark_Denton.

iPad Pro 9.7inch iOS 10.3.2

That doesn’t work unfortunately

didn’t work sadly :(

Did Apple reject your payment or you didn’t able to buy a subscription before doing your payment?

it crashed when i tried to click on the purchase buttons on either subscription

Hmm, I think we should wait either Mark or Tyler’s response on this

1 Like

This doesn’t sound like a problem with Infinite Flight. I strongly suggest you contact Apple Support (800) MY-APPLE as it might be an issue with your iTunes account. If it’s an issue with the app, I still suggest you contact Apple as they usually go through some troubleshooting steps with you.


1 Like

You can also try adjusting some of the settings in the ‘settings’ app for IOS. Also, make sure that you are signed in with your Apple ID.

How is that video related to his problems…?

Because if his phone is laggy it shows what settings to adjust.

Totally irrelevant if you actually read the post.

The same happens when I’ve launched IF without internet, kept it open, and joined a wifi network/turned on cellular data. What normally works is double-tapping the home button, closing IF, and re-launching it while connected to wi-fi; try and see if that works.


All solved Don’t worry


How did you solve it?