Not able to tune into tower frequency

I was going to make a flight from RJAA just now, but when I am trying to tune into tower frequency I am simply not able to. The controller asks me to contact tower, however when I try to find the frequency it doesn’t show up in the list.
Anyone know why? Is this a known bug?

I think maybe it is because you aren’t close enough to the tower

If you’re un able to contact, to change your callsign to “NORDO” this lets them know of the glitch


I was holding short by the runway, so I don’t think that was the issue. Additionally the tower controller even asked me to change to his frequency, but I was still not able to.

1 Like

Can you do that in game? I had done quite some planning and didn’t want to start all over.

Yes you can

How, exactly?

I figured it out.

edit: how to change call sign in game

1 Like

When you’re in Game, go to the menu, then on the top right corner it should say your name and what server you’re on, click that it’ll then bring you to your callsign and waa laa!

1 Like

If you are not interfering with traffic, you can enable airplane mode until the live server connection shows up as red and then turn it back off.Then you should be able to tune in to the frequency.

I tried that by leaving the app, “disconnecting” from the live server. Still weren’t able to connect, not even after restarting the app.

Maybe this might help :)

Well I was holding short by the runway, in other words, distance should not be an issue. Also I tried to connect via the airport interface from the map, but it did not show up there either.

1 Like

The weird thing is that the controller I was trying to connect to: tower, was sending the call: “you’re in an active airspace” yet I did not get the option to tune into his frequency.

1 Like

Just for the information, I was perfectly able to connect to both RJAA ground and RJAA ATIS Information

Do you know if the controller logged off while you were trying to contact them?

He had been active for more than 50 minutes and tried to contact me several times. In other words, no he was neither connecting or disconnecting.

When things like that fail, you can always click on the airport dot, check the frequencies, make a screenshot (for your reference) and see if you can access Tower frequency by pressing TUNE.

I tried that, but tower frequency and the button to tune into it did not appear.

This is why you make the screenshot 😊
Just in case you ever need to prove something to the Tower ATC.

This may be just one of those one-of-a-kind issues that you can never reproduce and you just don’t know what happened and why.