nose tilts down on short final

When I am coming in to land I keep the speed autopilot on and when I hear the 100 ft callout I turn that off. Well as soon as I turn that off the nose pitches downward and it makes really hard to land. Is there a way to avoid that?

1 Like

Have you made sure that your device is calibrated properly before disengaging auto pilot?

3 Likes

Yes cause the only thing on auto pilot is speed so basically I am controlling everything else

i was just thinking that. What about the trim?

Could be trim cause I never use it actually just cause I never know how much I need as IRL I generally dont use it on landing unless I need it

I mean, before you disengage autopilot do you go to the pause menu and select calibrate? If you do, then great, but if you don’t it’s a great habit to get into and probably could solve the nose down issue you are experiencing.

I never use trim for my landings either, but don’t have a nose down issue. So it probably isn’t the lack of trim which is causing the issue.

I do the same thing where i leave the A/T on till i flare. I havent had that problem yet. I usually calibrate my phone twice and if i need to, use a little trim.

1 Like

Which aircraft? Where to Where? Gonna test it out.

I dont calibrate it on short final as I calibrate it before taking it off of the HDG and VS autopilot before final and it reacts as it should be

two flights

  1. FAOR-KATL 77L
  2. KSLC-KOAK CRJ9
1 Like

This is probably your issue then. If you’re like me, you don’t hold your device in the same position, the entire way through your flight.

Therefore it is always good to calibrate before takeoff and then calibrate again on final before you disengage autopilot.

Now that im thinking about it, that has happened to me on the 380. I tried using some trim before i turn the A/T of and the vspd and it helps

I forgot to add before final

Trim is what prevents this from happening. Use 20% to start with, start adding it slowly just before disengaging AP

2 Likes

I will try that. Even though I have not used trim before and before did not have the issue

If it works then it will solve your problems and make you flights more realistic I guess. Makes all the difference!

So I went back and coming on final I disengaged autopilot with no trim and it tilt down and then I used trim and disengaged it again and it did not tilt.
I then decided to try and land first with no trim and then do it again with trim but then I landed with no trim and it did not tilt down

What’s your speed and flaps settings?

my speed is 145-150 and flaps is 30 degree

It may be because you’re going too fast. If you slowed down I believe it will correct itself.