No update on Android??

No android update on my phone? HTC desire, android 4.4.3.

Thank you for contacting support!

Our minimum device requirements have recently changed due to the rapidly evolving features of Infinite Flight which require greater device performance and specifications to smoothly operate. To ensure the best possible experience we recommend that a device has at least 1GB+ of internal device memory (RAM). Our mission will be to continually optimize performance, however the bar must be raised with future features in mind.


iOS Requirements:

  • 64 bit device
  • iOS 10 operating system or later
  • Click here to see full list of iOS devices supported at this time

Android Requirements:

  • Android 5.0 (Lollipop) operating system or later
  • Device must support OpenGL ES 3.0

Note: Due to large variety of Android devices there is not a specific list of supported devices. Customers with devices that are not supported at this time will receive a message on the Google PlayStore when attempting to download the latest update for Infinite Flight to advise that the device in use is not supported.


We appreciate your understanding and apologize for any inconvenience.

6 Likes

You actually need Lollipop!

Hello Schyllberg,
i have a question if you are able to answer. Is it possible for me to install the update of infinite flight global if my android version is 5.1.1. Please could you help.

Yes!
5.0 or later, so 5.1.1 is fine :)

2 Likes

But when i go into the app into the app it still shows the old infinite flight. I tried installing and reinstalling but it does not work. Is it possible for you to answer this question.

Thanks

Try to uninstall, restart your device and then download again.

It is not seeming to work. So this could be a problem with Google playstore

Are you still experiencing the issue?

I am experiencing these issues

Have you updated to more than Android 5.0 now? Does your device support OpenGLES 3.0?

Yes my android version is 5.1.1

I’m not sure how to check this as I’m on iOS but it will probably show on your settings page or something

I searched on the internet and it says it does

support OpenGLES 3.0

In that case, I’m not sure. Try restarting your device and uninstalling then reinstalling IF. I would wait for a moderator as it seems very peculiar. Just make very sure that you have OpenGLES 3 and Android 5.0

Have you tried the suggestion noted above? Try Reinstalling the app and refreshing your device.

Do you mean reset your device

I have tried everything and it is so sad that i am not able to play globlal like others

What we meant was, delete the app (Infinite Flight) and then reinstall the app.