No engine blades on 747-400, 747-200

For a while now, there is no engine blades on the 747-400 or 747-200. They used to be seen now they are no longer there. I’ve restarted the app, cleared cache, restarted my iPad, but to no avail. My device is a iPad Pro 12.9 64gb, latest IOS, Latest IF version. Here is an image:

1 Like

What airline that 747 planes

It’s on every livery. Not just one

This is because the developers have not added this lol

1 Like

Are you sure it’s not always been like that? A lot of the older aircraft have 2D flat engine fan blades

1 Like

I believe they used to have blades.

2 Likes

Nope, They used to have blades, you can look at the Best Phoros thread and the photos have blades

Yes they have, the aircraft did in fact have blades and for most it still does

1 Like

I would try reinstalling the app entirely so you have to reinstall that particular aircraft

1 Like

Already tried that, twice, still hasn’t worked

Already working??? @daniel14

No it is not. The issue is still there

Yeah I checked, their aren’t any on best IF photos.

And all aircraft settings are on the highest setting?

1 Like

They definitely were there.
Maybe uninstall the app and re install? Nothing else has worked.

Yes that is correct, all setting are on high.
@Infinite_Flight_Dude The 747 family does have blades I have images from a few months ago
@Sammy_Droubi doesn’t help

1 Like

May I see them? I guess I can’t find any photos :\

It might be the new update and they made a little oopsie just like the 747 telescope

This was from February 9th of this year

1 Like

Is anyone else other than Daniel experiencing this issue?

2 Likes