No building SCEL

Hi guys, so I’m here to report an issue that happened twice on my flight to SCEL, I know there’s 3D Building at SCEL but Whenever i’m doing a long haul to SCEL once I get there there’s always no building (okay this the second time only) but I think something must be happening so I decided to let you guys know about that.

my flight was from LFPG to SCEL, flight time 13 h 30.

frist time I didn’t do anything because I thought must be the cache thing maybe I should clear it before landing but this time I did and same thing still happening.

Just to make It clear I do have building When I spawn at SCEL but I don’t have it When I do a long haul to SCEL If that make sence.

What version of Infinite Flight are you on?

Version 21.04

Maybe try going in graphics settings and messing with the object density toggle, worked for me at Heathrow and Jeddah

Yes,I’ve tried this A few times too,maybe it can work for you too. @joslleymiguel_holand

Tray respawn and they normally show up again

This also happened to me in the past. I fixed it by not messing with the ‘3D Object Density’ in the graphics section. When I did long hauls, I would turn all of the graphics low including that. If you’re on the ground, you can change the object density and the buildings should re-appear.


I will try that, I pretty much do long haul all the time and It never happened the previous one before this flight was LFPG to WSSS and nothing happened, btw I never messed with the setting before.

surprisingly It happened again at the same airport, but will try your Suggestion and See what happens, thanks

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.