No airport

I was on final visual runway 25C and suddenly the airport disappeared and I turned on the appr but it was to late and I had to go around but also the runway did not show. I want to know what to do so this do not happen again

Hi!

Be sure to head to your general settings, scroll down to the bottom and clear your scenery cache. Please let us know if this works.

1 Like

you just got the low quality airport edition

I tried but unfortunately it didn’t

1 Like

I had the same issue once because of some Global Server issues. Maybe that’s something you can check

1 Like

Please read this before posting

I would recommend restarting the app and then clearing the scenery cache once again. This happened to me before. 👍

2 Likes

Happened before to me. Clearing scenery cache wasn’t enough, so I restarted my device.

2 Likes

@Aniket_Joglekar no where in that post does it say how to fix a missing airport issue. Please avoid clogging the thread.

@Omar_Osman,

  1. have you experienced this before?
  2. have you tried shutting all the way down and restarting?
  3. have you tried to uninstall and re-install?
1 Like

Yeah, that’s pretty crazy. Some airports aren’t accurate. Sometimes you land, and then you realize that the airports doesn’t have gates, but I’ve never seen an airport disappear.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.