Nexus 9 Tablet not charging with Infinite Flight Open

I have a Google Nexus 9 Tablet so as you know its kind of an older tablet but Infinite Flight runs great on it. So my issue is that when am on a flight and i want to charge my tablet during flight it does not charge and starts to lose charge. But without Infinite Flight running the tablet charges fine. I have plenty of memory and storage, any help would be appreciated it. Sometimes when i connect the charger it will say charging AC and other times it says charging USB while plugged into an outlet. Somehow tablet charges when display says charging USB but does not charge when it says charging AC

I don’t know much about androids but try these steps;

  • Re-install Infinite Flight

  • Reboot your device

  • Lower some of the settings such as aircraft rendering etc.

See if that helps :)

Also switch this to #support as it is a IF related issue.

Hello!

Are you sure about your last sentence? AC charging should be faster than USB charging.
Explaining the differences would take a pretty long time, so I will just say what you can do:

As you know, IF needs a lot of performance to be able to run smoothly (especially in your case, the processor you are using is a 28nm-processor, which consumes a lot of battery). This results in a high battery consumption. So to equal it out, you need a good power outlet/adapter. Phones/tablets that support fast charging don’t have any problems (my S8 for example).

To reduce the battery consumption, lower your screen brightness, turn off/down the volume, lower your graphics settings (so that the CPU doesn’t have to work at nearly 100%), limit the frame rate and enable “Automatic Low Power” mode.
Also make sure that you are not running any other apps in the background.

If you still have the original charging adapter from Google, then use it.

3 Likes

Hello, and yes am sure about the last sentence and i know it sounds weird, but sometimes my adapter switches from AC to USB while plugged into the power outlet, when it says AC it loses charge while running IF but whe it switches to USB it does charge but slowly. Also could it be my processor is to slow if not am guessing something is wrong with my adapter or micro charger port. I wish it would stay on USB all the time but i cant control that. Ive tried lowering my settings but no difference.

Hey dude

I work closely with a lot of Google and android based devices.
My best guess is that there is damage to your charging board (this is based on an issue I had a while ago) which is confusing your device as to whether it’s charging via a USB or AC
As to your comment about it charging slowly on USB, have you tried using different power bricks to charge your device?
I find a lot of times that my older power brick, which has a lower output than my Google brick sometimes does a better job at charging. I would always recommend sticking with the charger provide, as these chargers are meant to suit your device charging requirements. Usually a 5v/ 2.1a plug is more than enough to charge your device whilst using IF

His processor is actually quite low power, it doesn’t drain the battery anywhere near as much as you think 😉

https://play.google.com/store/apps/details?id=com.primatelabs.geekbench
Id recommend installing this and running the battery capacitive test, as this will allow you to see if the issue resides with your battery.

Otherwise, make sure you have all developer options disabled, Bluetooth, any kind of wireless communication besides WiFi, close all background apps. Also make sure to clear your cache:
Settings- storage- explore- cache- clear cache

If you don’t have any luck with that, report back here. Obviously you need to remember that your tablet was produced in 2014 and only has a 6700mAh battery, which by today’s standards is very small. Your device has a powerful CPU and GPU which is why it runs IF well, However just remember that your battery is not up to scratch anymore.

3 Likes

^^^FYI, he’s the Forum’s Android Go-to Guy

1 Like

My Invidia K1 Tablet does that.
I just have to remember to unplug and replug my charger after I start up IF.

Thanks for the info, and i have not tried using different bricks i need to buy one as the only other charger i have is a fast charger for S7 but dont think that would work, and i know its an older model and im looking into getting a new drvice, as much as i like Android i think i will be getting an Ipad. Ive had way too many issues with my android tablets. Thanks for all your help.