Navigation database error. Game won’t start

1 Like

Hello There Mate!

A simple way of fixing that is by simply restarting the app. If that doesn’t work, try restarting the iPad. It could also be your internet connection. Just try a few of those things and tell me if it works.

Also, for next time, if you every run into a problem, and seak to find help, it might help just a bit more if you provide more information. 👍

1 Like

What device do you have? What version of iOS are you using?

Android. Galaxy Tab A from 2018. The first splash screen appears, the wheel at bottom of screen whirls, saying its updating the Navigation Database, then that error happens, repeatedly. Each time you press the Retry button the same error comes back. Cannot get into the opening menus.

1 Like

Hi Chris, sorry to hear you are having trouble. Just to ensure we start with a clean slate we have a few steps would like you to do. Could you follow the steps below for us:

  • Close Infinite Flight (make sure you stop it from running in the background as well)

  • Turn off your device completely

  • Reboot your router and wait for internet to establish again

  • Reboot your device and relaunch Infinite Flight

After you’ve completed this let us know if you were able to load Infinite Flight and the Navigation Database.



No to both. Cannot load IF cannot load Nav db.

Hmmm, since you have an Android device could you try resetting your devices network settings. This will not remove apps, photos and documents rather restore your network settings to a default. Make sure you have a Infinite Flight closed when you reset the network.

From the Home screen, navigate: Apps icon Apps icon > Settings > Backup and reset
Tap Reset network settings.
If applicable, enter the PIN, password, fingerprint or pattern then tap RESET SETTINGS again to confirm.

Once this is complete go ahead and relaunch the app.

Works fine on a Samsung S8 phone. Android.

Will try your advice, thanks


1 Like

That has not worked. Being a Samsung tablet, maybe its locked into an old version of Android? that your software does not support?

see screenshot.

Which device is your tablet and what operating system?

As I said earlier, it is Android. Galaxy Tab A from 2018. It is running Android 7.1.1 as per the screenshot I just sent.



Apologies, the screenshot didn’t upload earlier in your response. Last option here is to go ahead and remove the Infinite Flight app entirely, restart your device and install it again.

Did that. Works well on Galaxy S8 phone. For information.


Is this device connected to the same connection source (wifi or similar) as the tablet you are experiencing issues with?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.