Multiple UI systems fail in flight

This does not pertain to the Server crashes but to UI faults that arose from glitches. This is not about a user account. Read through before commenting

When flying earlier on a Flight from KATL to LFPG I was 400nm out from landing when I lost connection to the live server. At first the connection was going in and out of network connection error and network connection failure. All the while I was still connected to the Global server and weather. I also ran into some problems with User Account validation. This is not the issue however as I understand connections can go back and forth. What was the problem is an interesting chain of bugs/glitches arising from the failure to connect to the live server. I did try trouble shooting by coming off wifi and reconnecting and there was a change in status for all systems but once reconnected only the Weather, Global Server, and API connections were restored.

The first bug that arose was When pausing the screen everything seemed normal i could select all options and adjust times. The second time I selected the pause menu, I lost ability to select all items on the pause menu. This resulted in me being unable to calibrate. During the error when I selected an item with the pause screen showing my selections would not affect my pause menu but my flight systems behind the pause menu. I found this out from seeing the screen moving around the cockpit in pause menu and from trying to calibrate but deselecting my VS input. The only way I could exit the pause menu was to hit the back button on my S7. I tried using the home button and quickly going back into the app to see if that reset the pause menu inputs. It didnt however when ever selecting the pause menu now it would remove all of the UI for the flight and put you into a non HUD/systems view. Only using the phone back button allowed me to exit pause menu.

The largest mysteries were when I began to descend. As I began to descend and gain airspeed again the overspeed began kicking in even though at level flight of FL250 in an A330-300 I was at 300KIAS. Even with this action no violation for overspeed was sent because the connection between the live server and the flight had failed. in addition, when descending I noticed that the winds aloft did not change at any flight level but remained the same, even though weather had a good connection and was indicating it was being updated. I know that there are strong winds in Europe today but the velocity and direction was not matching up to what was being reported on the ground. While the winds was reported as 17G31kts on the ground the winds were a consistent 43kt at ground level.

Here are a couple of photos of the glitches reported above.

Screenshot_20171021-085003
Airspeed indicator

Screenshot_20171021-091222
Winds on ground remaining unchanged

Device Samsung Galaxy S7
IF Version 17.04.0
OS: Android 7.0

The systems were restored after restarting the app but I dont believe that the overspeed should be tied to connection to the live server and winds the same as Weather connection is stable. Im not sure if a failed connection to the Live Server would always result in this but it seems like multiple interfaces failed following a failed connection with the Live Server. THis all happened around 8am in the morning ART or 7am EST.

The live servers are having major issues right now. That’s probably what caused it.

I should clarify this was at 7am in the morning. Around 5 hours ago. Before the live server crash was happening. And please read through as the main issue is not the live server but the glitches that arouse from it.

2 Likes

The staff are looking into the issue to solve it at the earliest. Many players have been complaining about how they lost their flight at the end after a very long trip. It will be solved soon, nevertheless.

1 Like

Assuming someone from IF looks at the thread so I don’t have to open a new one…

Only device I have active with the account and it’s cut my throttle for no reason.

This thread does not have to pertain to the LIve Server crash but the UI faults that arose from a lost of connection.

That’s similar to the issue I’m having. Connection to IF lost, came back and then said I was signed in on another location

That would be me. I lost my flight on final of an 18-hour haul from JNB-SLC. But I still got the hours in my log book

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.