Missing planes from my tower cam

I was just controlling KSAN ground on TS1 and my radar showed much more aircraft than my tower camera. The issue is I wasn’t able to see aircraft position clearly to make sure they didn’t taxi into one another. Any suggestions? Here’s some screen shots of the radar view, then the tower cam view. Thanks in advance!

You didn’t buy these planes so they don’t show.

1 Like

Is that something new?


No. If you didn’t download it it won’t show.

1 Like

Wow, I never expected that to be the issue. I really do learn something new about IF every day around here.

1 Like

I still see aircraft which I haven’t bought when flying and controlling… 😕


Or maybe your airplane count is too low.

1 Like

@GordenW: you see all aircrafts when controlling, including those you didn’t downloaded.

@Flightfan84: this is a quit known issue. I know it’s really difficult to control ground like this but you need to deal with it, that’s it.

1 Like

There’s some dots

1 Like

ahahaha, im laughing so hard when those guys believe what u said

Try turning on ‘Automatic Plane downloads’ in Live tab of Settings.

The issue is that their are more planes on the ground than the device can render. The best option is to turn on airplane boxes and tags, then you will at least roughly know where all the planes are.


That makes sense, I did have those turned off. My airplane count was set to high but the rendering thing makes sense. Thanks for your help.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.