Minimum device requirements

We are looking into raising the minimum device requirement for our future updates. At this point there is very little chances that our “global” update will reliably run on a device that has less than 1GB of RAM. While we are still optimizing as much as possible, we also need to set the bar a little higher so we have some room for future features.

One thing we are considering is to only support devices that have OpenGL ES 3.0 support which would greatly improve some features we have planned (also most OpenGL ES 3.0 devices should have >= 1GB RAM)

On iOS, any device in this list or newer would be supported.

On Android it is a bit more complicated: the easiest way might be to install an application like this one and see what is reported.

In order to help us decide on what to do next, feel free to vote below based on the type of OpenGL ES support you have on your device (please be sure before voting):

  • My device supports OpenGL ES 3.0 (or superior)
  • My device doesn’t supports OpenGL ES 3.0

0 voters

122 Likes
3D Buildings
Global Devices
Evolution of Global Flight
Live on iPad Mini 2
Evolution of Global Flight
Android 5.1
Samsung Galaxy S6 Edge Global Compatibilty
Unable to download latest update (iPad 4)
RAM - new device
I have not got the update, what do I do?
Will global be iOS 9
iPhone 5
Which is better for IF? Note 8 or Galaxy S8?
Old update
Ipad air 2
Can not download Infinite Flight Global
Update not downloading
Global update on short final
Pause mode issue
Congratulations FDS!
Global update
Android force closes
Samsung Galaxy S2 & Global.
Not compatible with Samsung S8?
App updated but doesn't show any new features when playing
No update in the Play Store
Can't start a flight in solo mode
Cannot fly global
Can't get the Update?
Can't get the update with Android 7.1.2
Update not appearing on my Honor 8. (Android)
Alcatel pop 4-6
All Confirmed Global Features // Global Q&A
Update to pro
Bonjour la puce Mali-T720
Can't upgrade to live
Global update isn't available
All Confirmed Global Features // Global Q&A
Actualización octubre 2017
App crash
Global Flight | Testers Tracking Thread
Old/New Subscription
Samsung Galaxy S4
too many bugs
Touchscreen issue still persist?
Global for incompatible devices
Subscription
No global textures in infinte flight
App can’t launch
App can’t launch
samsung galaxy tab s2
Qu elle tablette prendre
I pad
Can a Huawei Honor 6x run IF?
Kindle Fire not supported?
Global update
Subscription error
Can't log on to another device.
IF on tablet
Live server not connecting
IF crashes when logging in
I can not play live
Plane purchasing issue
I can't update IF on my Nexus 7 (2012)
Have BIG problems with installing the App
Tablet suggestions for Infinite Flight
Some questions
Kindle Fire
sony xperia L1
Cannot log in with Facebook
Nexus Player Global Support
What will happen to my live , refund?
Need suggestions. Trying to get the best. Thanks
I can't download the global update?
Evolution of Global Flight
Evolution of Global Flight
Can't subcribe to Infinite Live due to server error
Evolution of Global Flight
Update has been approved!
Evolution of Global Flight
Ipad air 2
Issue with global

Wow, thank god I have a 2016 IPad Pro! It is sad though that my trusty IPad Mini 1 cant get on the list… 😔

24 Likes

I checked the IOS list and it says that the iPhone 5s is supported.

7 Likes

Soooo what about you read the post and click on that link :) (it is supported, but this is one of the oldest so don’t expect a great experience)

35 Likes

Thank god! Sorry just got scared their for a second
Hopefully I can get the IPhone 8 when it comes out

7 Likes

I’m not sure, is the iPad 4 supported?
I think so.

2 Likes

I’ll try to download the application first. Hopefully my device is compatible 😊

1 Like

They linked the list look yourself

2 Likes

It’s not on the list. So no, it’s not supported.

6 Likes

Somehow it only reports like this


Hopefully it’s compatible

3 Likes

Just couldn’t belive it.
Guess I Need a new iPad.

4 Likes

Says on the version line: OpenGL ES 3.0

So, it seems like your device is supported.

3 Likes

Nvidia Shield K1 is at OpenGL ES 3.2.
Bring on Global 👍🏼

7 Likes

I got the same message. I’m quite confused…

3 Likes

Read what it says under “Version”. I believe you can ignore the pop-up message.

3 Likes

@philippe the 2017 iPad is missing in the list and its supported. Can you add a sidenote for it?

2 Likes

That’s what I did at first. It says 3.1 so that is probably good. Idk what the report button is for though. 🤔

1 Like

Click on the link provided and you’ll get an answer. Is it so hard? ;)

9 Likes

Before posting, please just read the list that has been provided.

4 Likes