Map Connect v2 | Providing joystick support in Infinite Flight

Did you update Map Connect to the latest version of v1.1.3?

Yes and I redownloaded it to make sure, but it shows up as connected yet theres nothing happening in game.

Updating to this version will reset your previous joystick assignment, maybe that’s the reason?

You are absolutely right I’m so sorry for overlooking that part. I’ll make sure to look at that after every update from now on 😭🙏🏼

1 Like

In fact I forgot to add a line of notice in the update, but you reminded me, and thank you for that :)

1 Like

Back to working fantastically. Its this mod alone that convinces me to subscribe to IF.

I keep getting a timeout error every time I try to connect it with IF. I’ve used it before and had no issues. Tried reinstalling it too, but still the same issue.

1 Like

are u using the latest version?

Yes, 1.1.3

Interesting, I’ll check that. Thanks for reporting the problem.

2 Likes

That would be great. I got the same problem

@AirChina196 @Alpha1Aviator

I had the same problem and have now found a solution.

  1. I started the game and Map Connect, then waited for the timeout error and closed Map Connect.
  2. Then I turned off Wifi on my iPad and turned it back on after a few seconds.
  3. Then I started Map Connect again and it connected normally.
    Even after several attempts, it connected normally and now works perfectly.

I hope this solves the problem for you too.

3 Likes

Good evening! Maybe there’s someone who’s had the same issue I have and can help me get this issue fixed…

I switched from a Windows 10 desktop PC to a Windows 11 laptop due to a military move I am doing and can not take the desktop with me. I am following all of the steps in the tutorial and I can not get Map Connect and Infinite Flight to connect to eachother. I have been able to correct the issue in the past but no matter what I have tried it does not want to play nice with me. Any suggestions on anything I might not have tried (literally anything at this point)

TIA!!

Anyone have any ideas or does no one use this no more?!?!

Hey, are you getting the “time out” error or are they both just not connecting?

Nope, just not connecting. I’ve reset both WiFi on laptop and iPad, and nothing. Maybe just out of a random shock and awe, should I try resetting my WiFi router?

Any advice would be appreciated as I suck using the iPad to fly!

To circle back, I reset the router and nothing is still happening. Is it just a thing that laptops don’t like doing these things?

Good possibility that maybe it could be time for a new release potentially?

1 Like

I recently bought the velocityone flightstick to try it out, and its great. It connects to the iPad through mapconnect just fine but theres a huge issue. I have set buttons for different functions in mapconnect such as parking brakes, but those buttons aren’t recognized in IF. Roll, yaw, tilt, and throttle work, but no other axis functions or buttons work, not one. Help would be greatly appreciated.

Hey not sure if you saw my reply, but it’s just not connecting. I’ve done everything I could literally think of in order to make it work, however it still isn’t working. I’d love to be able to go back to using my joystick sometime soon!