Map Connect Not Working

Hello,
I’ve been having some issues with Map Connect. For whatever reason Map Connect is connecting to Infinite Flight, but Infinite Flight isn’t reading it. I know this because when I go to controls, the “Connect to network joystick” button isn’t popping up. I tried with Liveflight connect just to see if it was something else, but it seems to be something with map connect because Live flight connect worked. I’ve already deleted IF and Map Connect and i re downloaded them and I’m still having the same problem. I need Map Connect to work because I have a Logitech flight throttle quadrant and a Logitech extreme 3d pro joystick and live flight connect doesn’t work with my throttle. Please Help!
Thanks.

Hello,

In this summer, we have put most of our attention to this software. Our goal is to release a new version of Map Connect, but due the any problems that might happen in developing, we haven’t set a ETA for the update, thanks for your patience.

1 Like

Is there anything you think I can do to make everything work?

Unfortunately, not my knowledge. Sorry :/

Ok, Thanks.

Hi, I am having the same problem with my Thrustmaster T Flight Hotas One, where Infinite Flight is not recognizing a network joystick. Is there any update to fixing this bug, Thanks!

3 Likes

Hey update to my problem I download the older version Alpha 1.0.0 on windows and everything worked pretty well. There was a tiny bit of lag but nothing to bad. I recommend trying this if you were having the same problem as me.

Well, I don’t have a windows computer so I really need it to work on Mac.

There is the older mac version of Map Connect. I haven’t been able to try it but you are welcome to.

1 Like

yeah, but the devs are working on an update. Keep updated on

2 Likes

I tried the older version of MapConnect on mac and it’s still doing the same thing. Any updates from the developers yet?