Mach speed glitch

I was doing an overnight flight last night, so I departed KJFK on ES, got her up to cruise at a perfect Mach0.83 (B77W). About 4 hours in (2 in the morning) I received an Overspeed warning and went downstairs to check. My game had glitched my Mach to 155.90 somehow, which gave me an overspeed lvl 1 violation. Is there any way to get it removed due to it being a system error? Thank you!

Device: iPhone 14 Pro
Operating system: iOS 17.3.1

It’s probably best if you keep that replay file for now for if it is needed, and last time I spawned inside the ground and got an aerobatics violation, it was removed, system level 1 violation errors usually do get removed without problems.

Yeah no plans on deleting it anytime soon lol, hopefully it does get removed bc the sim glitched my Mach that high for me to get a vio

Were you using any third-party apps?

Yes I was using IF-A for step-climb but I had all my speeds set to .83

Did you have any speeds set in knots? Did you use IF-A to climb through 28,000 feet?

No, I did my initial climb and cruise all by hand, then I set up all my step climbs with Mach .83

Interesting. Behind the scenes, the API requires the autopilot target speed be set in meters per second below 28,000 feet, and mach number above 28,000 feet. This can have some funny effects if the API receives the wrong value for your altitude…

I bet IF-A tried to set your airspeed to 303 knots (155.8 meters per second) while you were above 28,000 feet. Infinite Flight expected the mach number, and set your autopilot to Mach 155.

Keep an eye out if you’re using a third-party app to set speeds near 28,000 feet, e.g. if your first cruising altitude was FL280 before step climbing.

@epaga may know more.

1 Like

That is interesting, I only use Mach numbers when setting a step-climb so it’s interesting that it set it to m/s

This has happened to me before using IF-A; at no fault of the app. It’s easy to fat finger when setting up your speeds or step climbs in the altitudes and I accidently hit some IAS setting without noticing it. Actually happens quite frequently to me except now I catch it after that one time.

Fair lol, I just opened it to check, and all mine were set to M0.83 so it’s just a little weird still

I’ll do some testing as well, when I get the chance.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.