Long Haul Flight Issue

How do I make it so my phone doesn’t turn off during flight? I made the setting in iPhone to where it shouldn’t ever sleep, unless I press the button. But when I leave the phone and go outside, then come back in, my phone has turned off and my flight didn’t continue. Someone help!

1 Like

That’s strange when infinite flight is on the phone should not turn off.


This is a known issue and a fix is being worked on, your phone is crashing during the flight due to a lack of RAM which is a bit difficult to control.

1 Like

hm that is interesting cause if your plane is flying it should not turn off. when you mean turn off you mean it is at the home screen or the screen is blank where it went into sleep mode?

After an app crash it takes you back to the home screen of your device. On some devices it’s set so it turns off after a period of inactivity on a home page.

I know that but it sounds like it went straight into sleep mode

The title has me thinking that is an issue with long haul flights after some time, but the text says that the screen going dark (likely an app crash) happens very quickly, so I guess I agree with you.


@charrison What was your battery percentage and how good is your wifi? Also how much storage do you have left?

To test your wifi, click on this link and then click run speed test. https://www.google.com/search?q=wifi+speed+test&rlz=1C1SQJL_enUS880US880&oq=wifi+&aqs=chrome.1.69i57j0l7.2315j0j7&sourceid=chrome&ie=UTF-8

Maybe head over to settings and set screen time to always on… however it shouldn’t be a factor for infinite flight… maybe close apps running in the background?

sleep mode.

i have a lot of other apps in the background running. should i try and close those?

Yes of course try it and let me know if it works

One more question when you open and unlock the phone does it go straight to the app or is it at the home screen?

It goes straight to the app, but the app is at the home screen (like the screen with the logo when you first enter the app)

Hm interesting. Maybe @schyllberg could help cause honestly I haven’t heard of this happening

1 Like

I have found a solution @TylerShah. Go to Display & Brightness in your phone’s settings. (for Apple) Then press Auto-Lock, and choose never. That makes it so your device never turns off when you are doing long-haul flights!

I have done this, and it didn’t work. I will try to switch it to 5 minutes, then back to never and see if this works.

Hm. Maybe it is something with the RAM processor that it can’t take that much power.

I am not sure. I just got a new phone so probably not…

1 Like

I am on iPad myself and I upgraded to 4GB of ram. Phones only have 2GB of ram normally.

How do I upgrade? I have 111 GB of storage left, running on an iPhone 11 on the newest iOS software.