Logitech G Saitek Pro Flight Yoke Works?

Hi there, just got my new yoke and wanted to test it on IF.
Did everything, controls settings etc but says It’s not assigned.

And yes I have the live flight on my PC

So, can you use the Logitech G Saitek pro flight yoke? Cause Either I’ve must done something wrong?

Have a great day

Have you perused this tutorial and thread?


Yep, I used that one before.

Also, forgot to mention FYI I am using IOS.
Iphone 6s

1 Like

Ohh okay.
And also, I am connected to same network.
It says Network controller
And followed every step but still doesn’t work

Try restarting your device, reset your router and start from scratch. There may be a connectivity issue somewhere. Best to start over and go from there.

1 Like

https://www.amazon.com/Logitech-Saitek-Flight-Yoke-System/dp/B01M00OQBE Also, this is the one.

This yoke is supported. PM the people who use this yoke too and see how they can help you.

1 Like

Alright thanks, also are you the mod from Blu Games? If so I am ifpilot228 :P
Now I gotta cross my fingers for an reply from them!

Thanks for the help :)

1 Like

I’m using the Saitek Pro Flight Yoke also it works fine for me. I’m using it via OTG cable I’ll test live connect tomorrow.

Response time is accurate also.

1 Like

Nice! Patience , but sorta got the hang of it. :D

I kinda got mine to work. Throttle and yoke worked, but my rudder pedals would not. PM me if you need some help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.