Loading screen enigma

Hi guys,

I’m having a problem: whenever I load a flight, it never actually loads. It stays stuck on the loading screen, but i hear the sounds of the game. This is the screen it stays on:

I’m running iOS 11.1.2 on Ann iPhone 5S thanks a lot!

Make sure you have a strong wifi connection. Also, restarting the device pre-flight will help.

1 Like

@Arjun_Dayal I forgot to mention the strategies I have tried to use before:
-> Normal restart
-> Force restart
-> Memory cleaning app
-> Making more space on my device
-> Turning my VPN on
-> Restarting my router
-> Turning internet off and back on on much device

After all these, it does not seem to work anyway. This problem has just started yesterday, as two days ago I was flying perfectly fine on Infinite Flight.

P.S. Check out my Instagram account too ;) @regional_flyer

1 Like

You may need to uninstall and reinstall IF. See if that helps.


Yes this happened to me last week,so did the uninstall/reinstall. Worked fine for me, even iof a bit of a pain and lost the details from the logbook. (Though still got all my details and account details all ok as they area saved differently to the app.)

Also, give the game up to 5 minutes of loading before trying again.

When this happens, quit the app and try immediately to spawn again. Does the app load now?

1 Like

Unfortunately, no. I’ve tried quitting and flying again, but with no luck. I am currently reinstalling the app, however it is a little slow to download on school wifi ;)

1 Like

UPDATE: I have re-downloaded Infinite Flight, and it bien works perfectly fine! If there are any other problems in the near future, I will update this post. Otherwise, happy flying, and follow my Instagram account: @regional_flyer

Please don’t advertise. You can put it here: Community Instagram List

1 Like