LNAV button

Hello,i started a flight in the A330 when i took off,i realised the LNAV button doesn’t work,so i ended the flight to see if the problem continued i started a new flight to test the LNAV buttom and it worked,maybe it is a small bug in the app, can someone explain why it’s hapenned?

VNAV does not work on climb judging by what I see in the screenshot. You can enable VNAV once you’re at cruise and that will begin your descent at a reasonable distance from the waypoint you had set.

2 Likes

I said LNAV not VNAV

Well you said VNAV here so that’s what I was referring too.

Sorry my mistake but it is LNAV the problem

1 Like

What is the source set in your NAV?

1 Like

Ah alright, I searched through different topics and couldn’t find an explanation, my only solution would be to check if your source was on GPS and not NAV1 or 2.

3 Likes

VNAV unfortunately does not work during climb.

VNAV is glidepath information provided during an instrument approach, independently of ground-based navigation aids. An onboard navigation system displays a constant rate descent path to minimums.

LNAV is azimuth navigation without vertical guidance. RNAV approach plates include LNAV as a non-precision instrument approach (NPA).


Essentially, the two operate on their own separate functions. From the image you sent us, it can be implied that you are currently using the NAV1 function of the autopilot system. In order to get your LNAV systems to follow the set flight plan, you would need to go NAV → Source → GPS.

1 Like

Sorry but i ended the flight,but i’m sure i don’t change nothing in the GPS,NAV 1 or NAV 2

Issue Resolved! I am doing a flight and when I put “NAV1” it does what happened to @Bruno_Palma, and when I’m on “GPS” it’s back to normal, thanks @Pingu @ItsBlitz.

2 Likes

i inserted a flight plan from FPLtoIF with a SID and a STAR,it’s the first time i had this problem

Although @Pingu 's reply is much more in depth, I will just reiterate here:

The most likely thing I can decipher from your post is that you had set LNAV source to either NAV1 or NAV2. It needs to be set to GPS in order to follow your flight plan. If you set the source to GPS, it should work perfectly in future.

To add on to this, LNAV is selectable from NAV1 source if a certain ILS approach has been selected. If one hasn’t been selected, then LNAV will not be selectable.

You can do this by selecting the NAV option on your screen, then head to Source, then select GPS.

2 Likes

That is correct! Proven Fact, I did it! 👍🏽

yeah,i tested now with NAV 1 inserted and doesn’t work maybe i inserted NAV 1 and i didn’t realized,thanks everyone

No problem, glad to help! 👍🏽

Thanks everyone you can close the topic