LNAV Becomes Unavailable After Changing NAV Source

Version Information

21.8 (1385)

Device Information

iPad Air 4, iPadOS 15.1

Summary

Approaching MMUN, I tuned into the VOR CUN (113.600 MHz) on my NAV2. The NAV Source was changed from GPS to NAV2, with the intent to use LNAV guidance to track the inbound course using the VOR. However, my LNAV button greyed out after changing the source to NAV2. After toggling back to GPS and then again to NAV2, it became available again, and everything worked as expected.

Steps to reproduce

  • Launch Infinite Flight.
  • Start a flight.
  • On descent, tune into the desired VOR (in this case, VOR CUN, 113.6MHz) to NAV2. Program desired course into CRS2 (in this case, 305 degrees).
  • When at an appropriate point to hand-fly (temporarily), disable NAV, LNAV, VNAV, and take manual controls.
  • Change NAV Source from GPS to NAV2.
  • LNAV button becomes greyed out and only becomes available again after toggling back to GPS and then NAV2 again.

Expected results

NAV Source changes from GPS to NAV2 without any effect on LNAV availability, provided that NAV2 is tuned to something that can be used with LNAV, which in this case, it is.

Actual results

LNAV becomes temporarily unavailable after altering NAV Source from GPS to NAV2; it becomes available again after toggling from NAV2 to GPS, and then back to NAV2.

More Information

I was able to recreate it in a similar fashion on a separate attempt; the only difference this time is I switched to NAV1 first from GPS, before switching to NAV2. As seen in the below video, NAV2 remains greyed out (despite NAV2 being tuned to the VOR CUN), and it comes back as available when I toggle back between NAV2 and GPS once.

2 Likes

Happened to me…I just tapped ACT. LEG on my nearest waypoint and it worked.

1 Like

Able to reproduce.

21.8
iPhone SE 2020, iOS 15.2

1 Like

Technically, once you change your navigation source, your autopilot will work in coordination to the navigation source. For example, if I set a runway up as NAV 1 for ILS approach, and switch to NAV 1, my autopilot will change coordinates to apply to the NAV 1 navigation. This is normal, or so I believe. Someone please correct me if I am wrong.

This can be an issue at times if changing your navigation source from a further distance, but what I try and do is to activate my approach/NAV 1/NAV 2 when I’m headed straight towards the runway just before my final approach.

I experienced this issue, but it seems like it has been solved on my side.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.