LiveFlight Connect

Every time I open up LiveFlight connect to connect to my joystick it just says 0 for every thing. Has this happen to any of you guys, and if so how did you fix it?

Happy landing,

1 Like

Hi, this should be in #thirdparty as it’s not an issue with the app but with a third party software.

Can you confirm you have read over the setup guide and followed each instruction?

Also can we know the joystick model you are using?

It says that everytime you start the game up until you start your flight if thats what youre saying

Logitech x3D I know it works I’ve used it so many times. But recently I had to uninstall infinite flight because of the update. It work fine for like 3 days after that and now it does not.

And yes I have read the setup guide

Aha, alright.

I know this is blatenly obvious but have you:

  • turned Infinite Flight Connect on in the settings?
  • made sure the PC and your device running are on the same WiFi network?
  • turned off any VPNs?
  • reinstalled LiveFlight Connect?

Yep did all of that!
I just uninstalled lfc a couple minutes ago and it still doesn’t work!

Roger. Can you check if your computer actually recognises the joystick’s input? I suggest this website:

This is what keep happening!⬆️
Yep my joystick is on there!

And I’m assuming you’re actually flying when this screen shows up?

If so, LiveFlight is recognising that you have Infinite Flight open but cannot actually retrieve any data. Unfortunately there isn’t much more troubleshooting that I help you with. Although @Cameron is currently away and might not be able to assist you immediately, he will see this tag and reply to you whenever he’s free.

I’m sorry I couldn’t be of any more help.

Thank you for all your help

1 Like

The solution is to restart IF.

The user has surely done that already and it hasn’t worked out for him.

I did not read all the comments and that always works for me (restarting IF)


I use a joystick every single flight, with LFC. This happens to me every month or so, and to fix it, I completely delete LiveFlight Connect from my computer, redownload and install it. The issue is then solved. It’s annoying, but it works.

He has already tried that.

1 Like

In this case, I can’t offer any more possible solutions. Maybe try one more time?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.