LiveFlight Connect quit unexpectedly

Is anyone else experiencing constant LiveFlight app crashes on MacOs?

I’m running IF (18.2.6711.34008 iPad 6) on an iPad 5th Gen running iOS 11.4. [EDIT] I’ve just tried reinstalling IF with no success.

LiveFlight Version 1.5 (6) [EDIT] I’ve reinstalled this with no success either.

A MacBook Pro (Late 2013) running 10.13.4.

I’ve restarted everything multiple times, updated all available software, my network is solid 62.8 Megabits down…

This is the error:

Process: LiveFlight Connect [617]
Path: /Applications/LiveFlight Connect
Identifier: com.liveflight.connect.mac
Version: 1.5 (6)
App Item ID: 1078754162
App External ID: 825263421
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: LiveFlight Connect [617]
User ID: 501

Date/Time: 2018-05-31 15:53:34.924 -0400
OS Version: Mac OS X 10.13.4 (17E202)
Report Version: 12
Anonymous UUID: F7A53192-5264-1E01-4CE9-4974D19B0CE6

Time Awake Since Boot: 4400 seconds

System Integrity Protection: enabled

Crashed Thread: 6 Dispatch queue:

Exception Codes: KERN_INVALID_ADDRESS at 0x00007b381a79bec0

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]

VM Regions Near 0x7b381a79bec0:
Stack 000070000f9f2000-000070000fa74000 [ 520K] rw-/rwx SM=COW thread 4
MALLOC_TINY 00007f86ebc00000-00007f86ec000000 [ 4096K] rw-/rwx SM=PRV

Application Specific Information:
objc_msgSend() selector name: timeIntervalSinceReferenceDate

(There is a lot more to this error, but I thought I would try to post what is relevant.)


Same is happening to me. I just restart Infinite Flight and IF Connect and it stops crashing… Until it happens again. Luckily it hasn’t happened during a flight to me yet.

That does not seem to work for me… :(

What are you using LiveFlight Connect for? Joystick of an app? If Joystick, which one?

Joystick, Logitech Extreme 3D Pro.

Possibly unplugging and the replugging in the joystick might work. Alternatively, you could reboot your Mac.

I’ve tried rebooting the Mac, and I’ve tried multiple USB ports.

Found this in a help thread. Try this diagnostic test:

This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

The purpose of this exercise is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login. Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. The instructions provided by Apple are as follows:

Be sure your Mac is shut down.
Press the power button.
Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).
Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on some Macs.

The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

Test while in safe mode. Same problem(s)?

After testing, reboot as usual (i.e., not in safe mode.)

Also, if you click out of LFC while connected to IF and the Logitech Joystick, it also has to possibility to timeout, crash, or lag.

I will try in Safe Mode.

I have noticed that if you aren’t in LiveFlight (a.k.a minimized to finder or safari, etc) the keyboard commands no longer work.

However, what I’m getting is a Unexpexted Crash error and a report log…

Safemode did nothing, hopefully a developer will stop by sometime!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.