LiveFlight Connect keeps crashing

I’m trying to get LFC to work, but no luck so far. I’m using a MBP 13 inch with all the latest updates and it just keeps on crashing. It does connect to IF but then after 15 seconds the program crashes. Using an S7 Edge and a Saitek X53 Pro joystick. I’ve tried multiple things:

  • Restarting both devices
  • Using an ethernet cable to see if it would make a difference
  • Reinstalled IF

What can I do to make it work?

Try restarting LiveFlight.

I’ve tried that about 30 times :-)

Here’s the order when you start:

  1. Plug in joystick
  2. Start IF
  3. Start LFC
  4. Wait for it to connect…
  5. Move you joystick and confirm response.

After a crash:

  1. Start LFC back up
  2. Wait for connection

I’ve noticed that switching cameras, entering flightplans, and using the number pad for ATC can sometimes cause a crash.

Thanks for your help but that didn’t work. It still crashed on me.

1 Like

Does it just crash randomly, or is it always after a certain button is pressed (in my case the cameras)

It crashes mostly when I try to use my joystick. It always says ‘no joystick detected’ even though it’s plugged in, but it does work when I assign axes with the joystick. However, I just let it open for a while and it also crashed without doing anything.

I wanted to send the log file to the developer, but the button ‘open folder’ doesn’t work and I can’t find the folder manually with the given path :-(