Liveflight Connect dosen't work

Hi!
I’m pretty upset that Liveflight connect isn’t gonna be supported anymore. I have read on their website and they said that they are gonna stop operating and updating the software.
So suddenly my Liveflight connect app just started to not work. I just deleted it from my computer and when I’m coming to the website i can’t find the download file again. It’s sad that they are gonna stop update it again but does someone knows how to download it anyway?
I need to play whit my joystick otherwise I maybe quit IF. :(
//Anton

Hey mate, I recommend you check out some of the following articles. Let me know if they help.

1 Like

Well. Now I can’t really find the download files for LiveFlight connect. Its works just fine otherwise.

Oh, now I understand. I’m not sure. @Cameron is your man for LiveFlight.

Thanks ;)
For the answer

While I can’t give the best support, I have one more idea. Below is the hope page, can you see where it says download?

I have tried that but when I have downloaded it I got like 30 system files and no software.
I get one names LiveFlight connect but when im starting it I’m getting error messenges and the app just shuts down for some reason

2 Likes

What device are you using?

PC: Windows 10 Lenovo ideapad 320
OS: IPad Air 2 or IPhone 7

1 Like

I see. As I’m not a Windows user myself, I can’t really help. All I can leave you with is the following article. I do imagine someone else will take my place in helping you. Cheers!

1 Like

You need to open LiveFlight Connect.exe.

Can you show me a screenshot of the error messages you’re getting?

1 Like

I also encountered this problem. Fortunately, there are still files stored in my idle laptop. If you need, I can send you an email.

Sure i’m sending it as soon as i can

Yes please :)


Then then the software just crashes

Could you show what’s on the black console screen behind?

I just updated something, download the zip file from the website and try again

2 Likes

It’s working now thank you so much!

2 Likes

The zip file doesnt work for me. After I extract all and open it says error. Turned off my firewall and still not working.