Liveflight Connect automatically closing

Before updating to 22.8, I’ve always used Liveflight Connect to connect my joystick for flying. Yes I understand that it is no longer supported but it still works pretty well. However, after updating to 22.8, when I tried opening the application, it closes on its own. This only occurs if I have started a flight.

I have tried connecting repeatedly, however the results are the same.

I’m using a Windows 11 for Liveflight Connect. It used to work before 22.8.

We may have made some changes to the API which broke LiveFlight Connect - I discontinued it a few years ago, so unfortunately this was bound to happen someday. Sorry


Understandable. Thank you.

Some changes to the API, so this is maybe the reason why IF Operations isn’t working anymore…? Since I downloaded 22.8 it won’t connect to IF Operations… IF connect is enabled…

Fortunately there’s another fantastic app that connects joysticks just fine.

Oh this has another issue

i can’t make my device “trust” the app

Check this out:

1 Like

Looking at that message, it seems like it’s for Mac users.
I’m a windows user.

Windows shouldn’t have a “trust issue”, can you send me a screenshot?

Give me a moment

Well that is incredibly unfortunate :(

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.