Live Sever Gettin' Funky

iPhone 7 Plus, running on iOS 12.1.1, jailbroken, but never when using IF (ie. I reboot my phone before a flight so it doesn’t screw me over)

Doing a flight on TS1- RJTT to KLAX. I am currently heading back to LAX (I overflew the airport/overslept) and my connection to the live server is not connected. Everything else is working- WiFi is up and is barely used, phone is very stable, and this is not the first time-

Back when I was in Poland doing a long-haul, the same happened for no reason when I woke up. My connection to liveflight connect is active, but I am not on the map for LiveFlight flight tracker. Any help would be appreciated.

1 Like

Does you phone have alert type notifications on?

Have you tried turning on Airplane mode for 30 seconds?

1 Like


No, I have my phone on do not disturb; only IFAssistant has permissions to give me notifications.

1 Like

probably has something to do with the fact that you phone is jail broken… And restarting usually doesn’t get rid of the “Jail break” it clears ram and just restarts everything, not to smart when it comes to jail breaks… and i did some reading and it just seems like a lot of work to un-jailbreak your phone and then redo it again… I saw the many different steps. Holding the power button and then turning it back on wasn’t one of those… So chances are your device is still “Jailbroken” And if it is that’s where i would start when it comes to your connection problems.
Want to discuss more in a PM, please do because i am interested in how this all works:))


Mate- iv’e been jailbroken for two years, appreciate the help, but force-rebooting your phone gets rid of all tweaks. All that is left is the graphic UI/interface cache (jailbroken apps still shown) but my phone is not jailbroken- I can guarantee that’s not the reason.

Check if you are connected into any VPN Network of some sort?

1 Like

Thought about that too- no trace of VPN or any sort of network alternations being done.

1 Like

Have you tried to reinstall Infinite Flight? Maybe give this a try. Be sure to back up your replay files before doing so.

1 Like

pfft- replay files.

Jokes aside, ill be doing that right now! I’ll keep ya posted :P

1 Like

Schyllberg or one of the other mods said infinite flight might not be support on jail broken phones

This could be one of your problems and it was actually Chris lol

Do you have a stable wifi connection? Or does it cut in and out time to time?

Root vs. Jailbreak-
Root is android, Jailbreak is iOS- as stated before, I am never jailbroken when playing IF, only when using my phone as a daily-driver.

Yep- Xfinity 100Mb/ps in Chicago is something i’d call pretty stable. WiFi never cuts out.

Does it happen with every flight or was it just that one? Are you seeing anything on your session or is your only indication that something is wrong in Live Flight?

Root/Jailbreak still matters. You cannot say 100% that there’s not anything behind the scenes is different from an identical device not modified. It introduces an untold number of variables which is impossible to support. This is the same logic with not supporting emulators.

1 Like

True. There currently is no simple way to just eradicate jailbreak completely. I haven’t had problems before with my jailbroken iPhone, this has been since I went overseas (4mo ago ish)

I can assure you though, nothing can be running, the jailbreak is *untethered, meaning after a reboot no tweaks can run. It is impossible for any sort of jailbreak to run without my phone being jailbroken. The only thing that stays are the apps via jailbreak and their data (data idles)

I also see what you’re saying about the impossibility of ruling out jailbreak as a cause. I’ll do a long-haul flight now and see how things go. (Infinite Flight just re-installed)

May I ask where you went - as this could have something to do with it.

He was in Poland.

Wi-Fi Isn’t the best there though… before you @ me I go to Poland every year so I know ;)


Essentially I was wondering whether he may have connected to a secret dodgy network or something

1 Like

you see this occurs when your device does not sync with the if server for more than 4-5 minutes. In such a case you get disconnected from the live server and you can’t be seen on live server. Try using a very stable web connection and try using cellular data if able.