Live server

Hello folks…
I’m performing a flight from OMDB to RPLL onboard B777… I’ve been flying for 7 hours and 15 minutes with 52:24 minutes remaining where suddenly the simulator stopped working… My internet connection is strong and stable with no issues with any other devices… I tried to take over in order to prevent the server from kicking me out, everything worked again except that the live server has been disconnected… All of these issues happened in just a minute where i tried to get the game alive but with no avail. It’s unfair to be kicked out from the server due to an issue out of your control and lose a flight of 8 hours… It wasn’t my fault neither the internet connection which was stable with no issues… How to get again to the live server to record my landing as this wasn’t my fault and it’s unbelievable to lose a long flight like this one…
Thanks in advance for your help

did the server kick you for inactivity of some sort?

Happened to me before. I just ignore it and carry on with my flight until the live server comes back. This should work if I am understanding you correctly.

1 Like

That seems to be the reason… But i was trying to get the game alive after it suddenly stopped working (the aircraft and the strobe lights stopped but the sound was on)… Immediately i tried to react but nothing improved… When it get back by itself; I found myself disconnected from the server…

I will continue the flight for sure but i will not have my landing recorded neither the replay as well… I believe the server will not be connected again

If I remember correctly you still get xp and the landing. The live server usually comes back for me after a few.

1 Like

If you get kicked for inactivity there’s really not anything you can do unfortunately. The server will kick you from the server for inactivity. If this is the case I’m going to switch this topic category since nothing is wrong with the app itself.

Wait a second. Is the app frozen?

This looks like the very same issue you had the last time:

1 Like

My complain is clear… I wasn’t inactive… I took over immediately but the simulator was inactive… I couldn’t tap on any button neither pause the game… Everything happened in less than a minute… I had this issue before and the connection was the culprit, but this case is completely different as i was sitting near the game watching everything

Ok let me get this straight. So the app froze and you are experiencing an issue with the server? I’m sorry if I’m misunderstanding. 🙂

1 Like

I know! That’s different as it happened in just less than a minute where i couldn’t do anything as the simulator stopped working by itself and I couldn’t do anything as the screen was irresponsive

That’s exactly what happened… The app froze (no strobe lights and no aircraft movement); just a sound… Nothing happened when i tap the pause… I did not quit by home button as i know this would terminate my flight… When things worked again by themselves; the server was disconnected


At that point this is a concerning issue that you should look out for when performing long hauls (Since this happened again). If this happens, try turning on Airplane mode for thirty seconds, and if this doesn’t work, there is nothing I can do to help you unfortunately.

We had a similar topic like this and it’s a known issue the staff would hopefully take a look at. This problem is repeating itself a lot of times. This also could relate to your internet provider (ping).


I had the issue of freezing screen + not being able to press any buttons on my old iPad. It usually solved itself after some time (e.g. 30 seconds) with the live server connection coming up shortly afterwards.

In my experience it helps to close all other apps before the flight and ensure the device is not overheating due to sunlight or constant external power supply.

The issue has been there for more than 10 minutes and I believe the server will not get connected again as this happened to me before due to problems in my router… But now; the story is different as everything was working perfectly particularly the connection… It was stable and good

Have you left the app somewhere for a few seconds before the issue?

All right, got it, sorry I couldn’t help!

1 Like

That’s extremely annoying as it happened right before my arrival… It’s a bad feeling when you spend 7 hours in a stable and good conditions and just before arrival everything got bad🤦‍♂️

I do always leave the app in long flights and checking it regularly to ensure that everything is good… At this moment; l’m literally sitting in front of my iPad watching the flight where suddenly the issue happened and I couldn’t do anything