Live flight connect controls doesnt work

Yes, ive seen the tutorial, so you dont have to send me the link, but i just cant connect my saitek yoke/throttle/rudder to infinite flight via liveflight connect. Ive done everything right but it just doesnt work on infinite flight. What should I do? Anyone that has a yoke/throttle/rudder, could you help me? Thanks alot.

Hi!


Could you give us a bit more detail on what you’ve tried?

  • Have you tried resetting your wi-fi router?
  • Have you tried reinstalling the LiveFlight app?
  • Do you have “Enable live flight” ticked in settings?
  • Are you sing an external computer? (iOS)

What devices are you currently using?

Hey!

Im using a samsung Tab 3, I’ve deleted liveflight and reïnstalled it but it still doesnt work. Enable liveflight is also ticked on. Live does connect, but the problem is that when I want to setup my yoke/throttle/rudder it doesnt recognise it. When i click on show devices in IF it says: 2 devices

Accelerometer (2axes, 0 buttons)

Network controller (512 axes, 1024 buttons)

I hope this gives you enough information :)

Have you tried using them individually? Does it work if you only connect the yoke?

I just tried it individually, but unfortunately it didnt work either.

So both the PC and your Infinite Flight device are using the same wifi? If one is wired to the network and the other is on wifi it wont work.

90% of the time connection issues are firewall related either at the PC or router level.

What device are you using?

1 Like

Im using a samsung tab s3 for infinite flight, and a Lenovo laptop for live flight connect. I have tried this a few months ago but back then it worked, so its really weird it doesnt work now.

@Chris_S @BravoCharlie so my setup looks lik this. My tablet is connected to my yoke via a usb. My yoke is connected to my laptop also via a usb. And the other devices (throttle and rudder) are also connected via a usb to my yoke (on the back of my yoke there a 3 usb ports).

So why are you using LFC if your yoke is connected to the device directly?

The tutorial says you don’t need LiveFlight Connect if you are using a Samsung device, as you can connect them via USB. Also, since it is a Samsung, connecting the yoke directly & via LFC might cause errors in the device reading the two inputs.

Well, this was the only way it worked a few months ago, by connecting the tablet/phone directly into the yoke.

I just closed liveflight connect and it still doesnt work

I disconnected LFC but it still dont recognise my yoke on my phone, when its directly connected to each other

Have you used LFC by itself as well?

I have, but it doesnt work :(

Make sure your pc is public or private wifi. He has to be in the private. Public it does not work.

Ah okay, that’d probably be the problem. I dont play infinite flight with a yoke (etc.) anymore, since i got p3d. So i play infinite flight by tilting the tablet. Thanks for reacting though :).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.