Live connection drops when flying with ATC.

Hey guys.

I’ve had this issue for a while now and it’s beginning to effect the playability of the sim for me.

I can fly for long periods without any connection issues. I can fly with large groups and busy airspace with no issues. I can jump in the ATC seat, have a busy airport and no connection issues. But…when I’m flying and ATC is active, every single time I will lose my connection to the server every couple minutes or so and I’ll be recconected after approx 15-20 secs. Now while I could deal with that if I was in uncontrolled airspace no problem. But when I’m being controlled my disappearing and reappearing aircraft is going to be a headache for the controllers, so much so that I just can’t put them through it and leave the session, forced to fly in another region on unicom.

Anyone have any suggestions to fix this?

Like I said before, no issues in any other situation so it’s not my Internet connection.
I’ve reset the tablet, I’ve reset the router, tried many options, no luck.

Thanks in advance guys!

1 Like

I am not sure at all

Of what you aren’t sure?

That his connection goes when he’s in a controlled but not anywhere else

Read good the topic,if he said that is because he know,he did lot of test,is looking for help.

But he’s saying the issue happens when he’s being controlled

I have the same issue sometimes. If I enter a populated region with active ATC coverage I will notice my connection symbol going orange more frequently. I’ve never completely lost my connection but I have lost the ability to communicate until the signal comes back to green, in which case I also have to re-select the source I was communicating with previously. The common variables that I have noticed are:

  1. How many people are on my wifi network
    -Taxing the wifi network has made a big difference in me staying connected in the green
  2. How populated the region is.
    -This isn’t as common of a problem, but I have noted in the past that if flying a region that’s well populated with pilots and ATC (such as FNF) I can also drop in and out of the green.

I have been able to improve the issue (though not completely) by restarting my device and resetting the router. Going around the house and deactivating other devices that may be drawing some wifi signal has also helped. In the end I’m convinced that a more suitable router will fix my issue. I base this on the fact that when I play off the Verizon LTE tower I never have these issues, thus to me the issue is isolated to my home network or perhaps my ISP. Apologies for the huge post, hopefully something helpful can be pulled from here. Best of luck to you.

Thanks for the detailed reply. Mine is the same with regards to re-selecting the controller. When I’m online, there’d be 4 devices in my house connected, my tablet, my phone, wifes phone and the TV.

Your comment about using the Verizon tower suggests I should probably try on another connection and see how that goes.

Cheers

1 Like

I’ve had this happen now and then in high traffic on my iPad Air 2 (using wifi), but I accept it because I have all settings at the highest, so it’s likely to happen in high traffic areas.
Don’t know what your device is, but lowering the Airplane Count Live setting will help.
Also don’t use cellular networks by default. Always go for WiFi first.
One more thing, restarting device power often helps a bunch.

3 Likes

This was happening to me the other day. I just restarted the app, and it worked just fine after that. I have all of my settings/graphics set to the highest, and airplane count high. It may be frustrating during the middle of the flight, but I just continue, and wait for it to connect. Patience is often a temporary cure

Thanks David, I’ll give the airplane count a go, see if that helps. I’m always on WiFi, my device is the nvidia shield so naturally all settings are high.

Also in response to matt it’s not being frustrated about it mid flight or anything, I’m more concerned for my ATC brethren who have to deal with this appearing and disappearing aircraft on their radars. Not fun. Also when this happened once before I reset and yes it was fine after but now even with a reset it seems to happen still.

Anyway I’ll take David’s advise and give the airplane count a blast, if that doesn’t improve it then I’m stumped.

Cheers guys

1 Like

Dayumn that must be annoying 4 u, buuut its never happened to me so i dunno what it feels like

I’ve now tried every option possible and had no improvement. Reduced airplane count to the lowest possible. Reset tablet and just now re-installed the whole sim, still no luck. I checked with the TS and and it happens there too.

My Speedtest result:

Your speed is acceptable, I wonder if your router signal is consistent. Were all other devices off of the network during your test?

dayumn, still happenin? man dat sounds annoyin, but yeah the speed is acceptable

Ok, I may have sorted it. Just been on a flight whilst Seattle was busy and no connection issue.

My router has two ghz options, I’ve always been connected to the 2.4GHz channel. I’ve now connected my tablet to the 5GHz channel and I’m not having the problem anymore, I’ll keep testing it in busy airspace but hopefully that’s it sorted now!

Cheers.

It’s always nice to provide your own solution.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.