latest Ipad Verison supported?

Hello there

When digging out my old ipad mini (first generation) I decidede to update it and install everything that could be installed. Infinite Flight lists ios 9.3.5… which seems odd as this version is very outdated. However, I am running 9.3.5 and it is not installing. I suppose this is an error in the requirements list and should be fixed as I’d be positively surprised if IF still ran on such an old version.
IMG_3302|666x500

Thank you for contacting support!

Our minimum device requirements have recently changed due to the rapidly evolving features of Infinite Flight which require greater device performance and specifications to smoothly operate. To ensure the best possible experience we recommend that a device has at least 1GB+ of internal device memory (RAM). Our mission will be to continually optimize performance, however the bar must be raised with future features in mind.


iOS Requirements:

  • 64 bit device
  • iOS 10 operating system or later
  • Click here to see full list of iOS devices supported at this time

Android Requirements:

  • Android 5.0 (Lollipop) operating system or later
  • Device must support OpenGL ES 3.0

Note: Due to large variety of Android devices there is not a specific list of supported devices. Customers with devices that are not supported at this time will receive a message on the Google PlayStore when attempting to download the latest update for Infinite Flight to advise that the device in use is not supported.


We appreciate your understanding and apologize for any inconvenience.

The iPad mini 1 I should no longer supported by Infinite’s Flight as it is an old device that isn’t 64-bit and doesn’t support OpenGL ES 3.0

That was frighteningly fast… However, I knew that and wasn’t really what I was pointing out… I’m just pointing out an error in the requirements list of the app, which should be corrected. I have no intention in trying to run IF on my old outdated ipad mini.

It’s a bit weird on Apple’s side. That’s what causing this.
You can run it on 9.3.5, but the device you’re running it on must be an iPad 5th Gen / iPhone 5S or later…

But they display a very confusing message instead.

We’ve identified and working to have Apple correct it. They reflected it incorrectly! Thanks.

1 Like