Lag when entering an active runway

I have been trying to fly for a while now, but whenever I do, a lag occurs and makes the aircraft uncontrollable. I have seen that there are topics about increased lag, and if any are like this one please allow me to request this be closed.


This has only occurred to me so far at KVGT in a Cessna 172 (N1322K), and at KLAS in a Frontier A320 (Hugh the Manatee).


What happens?
So, after entering the runway area, the game starts to lag out and freeze, slowly getting worse and worse. When I was flying the A320, it was very difficult to look around the flight deck, or adjust my autopilot during the first few moments after takeoff. I quit shortly after, as I did not want to revive any speed violations.

I tried again a few minutes later, but this time I was at KVGT (just north of KLAS) to do a little pattern and speed work. Everything was perfectly normal until I crossed the hold short marker, and then the game lagged out. I attempted to continue the taxi out to the runway, however the rudder was glitchy and somehow the Cessna 172 ended up going in reverse. I quit after that.


My device/IF specifications:


Device

  • iPhone 7
  • 32 GB storage

Infinite Flight

  • High Rendering Quality
  • High Rendering Resolution
  • High Texture Quality
  • Anti-Aliasing ON
  • Limit Frame Rate ON

I know one of the first things to be said will be that “my settings are too high”, however I have been running on these same settings for longest time and have never had any issues.


I appreciate any help in advance, thank you!


Have you tried turning the settings down a notch, the iPhone 7 is quite an old phone

1 Like

I think this is likely due to the airplane count, what is it set to?

1 Like

I would say the high graphics may be a bit too much for your phone, try medium to low, see if that works!

1 Like

I will try all of your suggestions, give me one second!

1 Like

My airplane count seems to be set at medium.

With recent updates I have it set to low while taxiing but then on none during landing and takeoff to reduce the lag.

1 Like

@anon77793723 and @Kyan_Perry, I just tried it on medium settings, and it did not seem to lag at all. Then I tried it on high settings again, and it did not lag. Maybe it was something other than that?

No idea, I have an Xr but I use medium setting and frame rate thing just to save my battery so it can stay stron for the next year until I receive a new phone

Un-install the app, restart your device, and re-install the app. I have been having that same issue also especially when my game is crashing. Thanks to @schyllberg for helping me!

Yeah, the app carries a massive amount of data and resetting it removes all the scenery data so the phone handles the game better, I once deleted it from 12GB to the base MB

1 Like

I would like to avoid deleting the app, if possible. I just find it a hassle especially because my subscription is run by my dad, and he would have it re-enter his information.

I know but according to @schyllberg he told me to delete the app and re-install the app. But okay then.

1 Like

Thats good, maybe consider turning settings to medium or running high with anti anti-aliasing, you tend not to notice as much on smaller screens (i.e. phones)

1 Like

Uninstalling and reinstalling and reinstalling doesnt always make a difference with issues like these, this time it was most likely due to their settings being to high

1 Like

Actually, I’ve ran into several cases since 20.1 where it does. That specific procedure helps solve a lot of issues that might not be the most obvious once at times.

2 Likes

Its just a suggestion.

2 Likes

My bad, didnt realise that

2 Likes

Anything else I should try before deleting and reinstalling the app?

Why reinstall now when it seems to be fine?

1 Like