Lag on Expert Server

Hi, does anyone know why i get lag on the expert server, I never get lag on the training server even at busy heathrow, and I flew into an empty New York JFK a few days ago and there was huge lag, this has been happening for a while now.

try clearing the scenery cache, and or reducing some of the settings for IF

2 Likes

Try putting your graphic settings to medium and put plane count to medium
If that doesn’t work, put them to low and clear scenery cache.
Also, try to let IF be the only app running because having other apps running in the background may eat up your RAM and cause the app to slow down

Hey there! Please have a look at the Support FAQ 19.4 - Please read this before posting! topic next time if you experience issues with the simulator. It is very likely that your issue has already been discussed there. Here is the answer that is given on that topic:

General tips regardless of device:

  • Turn Limit Frame Rate ON (box should be ticked) if you notice that your device tends to heat up or if you are experiencing lag. A device that heats up too much is more likely to suffer performance degradation which could lead to lag and app crashes.
  • Infinite Flight doesn’t take up a specific amount of storage, it can change depending on the area you’re flying in etc. We therefore recommend that you always have at least 1GB of storage available on your device.
  • Before longer flights, it is advised to reboot your device and close any apps running in the background to enhance your experience.
  • It is possible to fly and charge the device at the same time. The key to this is to use less power than being charged. One way to accomplish this is lower your screen brightness and ensure Infinite Flight’s low power mode is enabled.
  • Disable active ad or message blocking apps
  • Don’t modify, “Root”, or “Jailbreak” your device
  • Use a strong WiFi network within a relatively close proximity to your device
  • Lower Infinite Flight graphics and performance settings
    1. Lower the Rendering Resolution setting.
    2. Disable Anti-Aliasing.
    3. Lower the Rendering Quality setting.
    4. Lower the Texture Quality setting.
    5. Lower Airplane count.

At any point if you’re experiencing decreased performance, “Limit frame rate” should always be ticked. This setting can have a great negative impact on performance unless your device is considered high performance.

If you are on iOS, click here to expand.
  • One great thing to do before launching Infinite Flight, is to perform a soft restart of the device. This is a quick and reliable way of making sure your device is operating at peak efficiency. This is done by holding down the power/lock button until you see “Slide to power off”. Then hold down the home button until you’re returned to the home screen. For iOS devices without a Home button, a restart is recommended as the soft restart feature does not exist on those.
  • Make sure you don’t have “Low power mode” on your iPhone. If you have, the battery icon in the top right corner is yellow. This can be deactivated from Settings -> Battery, or from “Control Center” depending on how you have it set up. Having “Low power mode” enabled while using Infinite Flight could result in a performance degradation.
    Note : This is not the same as “Low power mode” in Infinite Flight. This is a device function.
If you are on Android, click here to expand.
  • Make sure you have Android Battery Saver disabled. Having this enabled can cause a lot of degradation in terms of both storage, performance and network.
  • Newer Android devices may work fine with Anti-Aliasing on. Turning this off can help performance for older/less powerful Android models.
  • Some devices (ie Samsung) may have a Game Tuner app to enhance the performance of games. While some users have not seen an issue there is a number who have. It is best to run IF by itself instead of through a game tuner.

Hopefully, these suggestions help you out, take care! :)

3 Likes

Thank you so much, I will try now :)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.