Lag at busy airports

For some reason I would lag every time I am at a busy airport. My game would only do fine when there are little to no planes at the airport. This is the reason why I cannot participate in the “Friday night flights.” I think it’s because of my internet connection but is there any way to improve it?

You do have some options:

  • Ensure limit frame rate is enabled in your settings
  • Lower your graphics to low or medium
  • Disable anti-aliasing
  • Lower your aircraft count
  • Keep background apps closed

As always, make sure you restart your device before flights and resetting your router occasionally should help too. Hope these bode you well.

2 Likes

This is also caused depending on your processor. Take an IPhone X E. G. It has a great processor so it runs great.

I know this problem. You can set your airplane counter to ‘low’ in the settings. Hope it will work.

Well I’m using an IPhone 7 Plus

I tried that and it didn’t do much

The iPhone 7+ shouldn’t lag, not even at busy airports.
How much storage do you have left?
What iOS version is your device running?

Refer to this thread on options that you can use to minimize the amount of lag.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.