Keyboard doesn't work

I bought a wireless keyboard specifically for flying in IF, but it doesn’t work with it. It works in other apps, I can search for things and type messages to other people, but it just doesn’t work. When I open the Show Controllers in the Controls menu in Settings, it shows the name and it says there’s one axis and 0 keys. I can set keybinds for the functions, but I cannot use them inflight for some reason. Could you help?

Hello!

PC / Keyboards aren’t really compatible with IF. There may be PC 3rd party add ons using the Infinite Flight API.

You may be referring to this: https://connect.liveflightapp.com/

Well that’s just weird, I can set the keybinds after all. Doesn’t make sense to me

Does your keyboard work on other apps, like google?

It does, I type in here with the keyboard even. I also can change my keybinds. A thing that does work (not as supposed to, but works nonetheless) is when I press the B key, which is for normal braking and not for parking brakes, the parking brakes get released, but then I cannot turn them on again. A thing I forgot to add is that my platform is an Android device.

When you have it connected, what does it display when you press Show Devices?

Have you tried restoring everything to defaults? You may have had B mapped to other items as well?

It displays the name of the device and then it says there is one axis and 0 buttons and that’s where I get confused, since I can edit the keybinds. I haven’t tried restoring the defaults, but I will try now that you have said it.

After some 2 minutes of troubleshooting, I can say with confidence that resetting the controls doesn’t do anything and the controls continue not working.

Can you share screen shots of your key binding? Have you tried mapping the brakes to a different key?

Now that I have reset the controls, the brakes are set to the semicolon, while P is set to the parking brakes, but still responds to B. I do not have any alternative/secondary keybinds for anything.

Can you see if anything else is set to B?

OK, so B is set for the normal brakes, NOT parking brakes. Semicolon is for Parking brakes but it doesn’t respond to that. Other than normal brakes, B is not set to anything else.

So what happens when you press B in the sim?

When B is pressed, it releases the parking brakes, but pressing it back doesn’t turn them back on, neither does the semicolon.

Can you try something else?This might have something to do with progressive braking breaking the keybind.

Well yeah, I have tried turning on all the lights (on the A350, master is up and running), I have tried pushback, I have tried flaps and spoilers, but none of those work

This is kind of a follow-up post from this one:


So basically what happens is that I can set the keybinds, but I cannot use them in flight. The troubleshooting steps I have tried are
Resetting the controls
I have a screenshot of the problem, which I can send. Can you guys help out?

Ok, another thing I have tried is working with the numpad and that sort of works.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.