Just Keep Loading

Hi all! How’s everyone’s day been? I’ve done 4 flights on infinite flight, and was just about to do some patterns in a Cessna, but this happened. Did anyone else just run into this?

Best thing to do is just to restart your device or the app

Jetphotos is also down. I wonder if they use the same servers and if they are down. This is occurring with 3 of my friends, too.

Make sure you have a strong internet connection, change room if necessary. If the problem persists, restart IF, if that doesn’t work try re-installing the app

1 Like

No, because I’ve tried everything and they are still down. Jetphotos and FR24 use the same servers as infinite flight so I’m guessing there’s a correlation somehwere

Have you tried restarting your internet modem?

No, because my internet is totally fine and I’ve been doing other things on it. If you try loading into the app, let me know if it happens to you. If not, I’ll wait it out

I have no trouble, I loaded a flight just to make sure it was fine.

I encourage you to give a little restart to your modem.

Another solution could if you restarted your device.

1 Like

It’s fixed now. Thanks

1 Like

Glad to help! :)

1 Like