Joystick suddenly not working

I’ve been using my Logitech 3d pro without any problems for over a year. But today just stopped working. It shows up when I click on show devices but it will not calibrate or work in the game. I’m using Galaxy Tab S6. Any ideas?


1 Like

Are you using LiveFlight Connect by any chance?

No, just a USB cable to the tablet.

is the adapter working
or the is joystick working on other things like your pc

It was working fine for over a year then it just stopped working today. I tested joystick and infinite flight on another device and it works. So it’s just not working with my Tab S6.

the other device is a pc or another mobile device involving the adapter?

Hello! Joystick works with my Xioami phone. My workaround right now is to use live flight connect for the joystick to work with my Tab S6. I suspect that Samsung must have pushed an update to my tablet that’s messing with USB controllers. Even my wired USB Xbox controller doesn’t work anymore (with another game). USB charging, display out and transfer are all working though. So strange. In infinite flight, when I click on show devices, my logitech shows up but no inputs are registered. Any ideas?

Alright I’m not sure if this works cos I have not tried it yet but It should help
On your phone enable developer mode

  • to Settings > System > About phone .
  • Tap Software info > Build number .
  • Tap Build number seven times. After the first few taps, you should see the steps counting down until you unlock the developer options. You may also have to tap in your PIN for verification. Once developer options are activated, you will see a message that reads, You are now a developer.

Once in developer mode enabke usb debugging this should override the new update hopefully

After updating my IOS device I no longer have access to use my side stick for IF. You are not alone with this issue. Hopefully IF can or a third party can help us get back to the skies.

1 Like

His using a android

1 Like

Hi! Yes, I tried USB debugging but still no luck. 😔

What version of the app are you using? It would be helpful if you can share a screenshot from Settings → About inside Infinite Flight. Thanks!

If you “Restore Defaults”, does the accelerometer work correctly?

Hi! Yes, the accelerometer works, joystick shows as available but inputs are not recognized.

If you try the joystick with an app like this one, are the movements detected?

Hi! Yes, it works with gamepad tester and other similar apps.

Maybe clear all data on IF app.
When you start it again you’ll be signed in but all prev settings are gone.
And you’d need to download every Aircraft again.

Hi! Tried that as well.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.