Joystick not functioning

I’ve bought the Logitech 3D joystick along with the OTG cable and plugged it into my Android device (OPPO R9) it does not recognize the device. What should I do? Don’t give me another of those instructions thingy I followed it.


Have a look at the below post, and if that doesn’t work, try a restart of your device.

It could also be an issue with the current version of Infinite Flight, so if all else fails, it may be best to wait a week or so until Global comes to Android.

All the best!

Nothing, stays the same. Do I need to connect the device to a laptop so it works? My phone has 4GB RAM using Android 5.1. Is there anything wrong with my set up? I spent $60 just for this.

I would try connecting a [computer] keyboard to your phone through the OTG cable. Just to confirm it will work ;)

1 Like

Hi Sir. Have you tried Laura’s process?

I have but it was not informative. I connected my Joystick to my phone but nothing happened.

Have you tested assigning movements too it?

Like moving the stick?

I fixed it! :) it was a very complicated process to get it to work. I will post on infinite flight how to use it if its not working! Cheers!

1 Like

If someone solved the issue for you, make sure to click the tick on the bottom of their post. It makes them feel good, and it indicates to the moderators that this support topic can now be closed.