Joystick not connecting to my tablet

Hey everyone! So I recently buyed and Logitech joystick and a USB connector.
When I connected the USB cable to the joystick then to my tablet,it still doesn’t show controls,we would be very grateful if anyone has a good suggestion :D

You have to say, and yell, “turn on” and it should work. In all seriousness record your self doing that. Now I’m serious, I don’t know, maybe something is faulty. What device? Software?

2 Likes

I’m using a Samsung tablet S3,I’ve tried all that and still not working…

1 Like

Weird. But I wouldn’t be surprised because of the fact that most joysticks are used on laptops, PCs etc. but not tablets. So they don’t treat this as serious.

You have to connect it using liveflight connect a link can be found here to download.

https://connect.liveflightapp.com

No… not for Androids.

He should be able to connect it directly to the tablet.

Isn’t the Galaxy Tab 3 old?

1 Like

Yeah but it’s still good,IF runs smoothly and I’ve never had one crash on it…

Yeah,you’re right,but it doesn’t connect…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.