Joystick issues

Hi, I recently brought the Thrustmaster T-Flight Hotas 4 as the T-Flight Hotas X is no more selling, but I am having issues with it on LiveFlightConnect here’s what I have done

  1. Live Flight is on same WiFi as phone
  2. It is connected
  3. Turned on “Use Networked Joystick” on phone
  4. Tried assigning axis’s but nothing

Can somebody give help or shall I return the joystick and get the Logitech Extreme 3D Pro?

Have you been trying to do it through your device or on your computer?

Yes I have plugged the USB into my PC

I mean how are you trying to assign the axis.

I haven’t got a mac but I try to assign it through my phone by pressing Assign and trying to move the joystick but there is no response

Has Infinite flight connect connected with IF? (When it’s connected you get to the setup page)

1 Like

Hi @SwedishFlyer, Yes it says Connected to Infinite Flight!

Have you restarted everything, phone, pc etc? Worth a shot.

Yes I have tried restarting and reinstalling LiveFlight

1 Like

Hmm, so correct me if I am wrong but when you try to set axis for e.g pitch, nothing happens?

Make sure you have ur Joystick in before you connect and try a soft restart of your divice-that always helps- if not than, IDK

1 Like

I go on my phone, I press Controls then Use Networked Joystick then Assign I try moving my joystick to the sides and back and forth, the yellow line stays as it is

Since liveflight connect and IF works, I’m suspecting that it’s something with your joystick. Is there any software you need to install on your joystick first?

Yea, I reinstalled LiveFlight, my joystick is connected to my laptop in a USB port

Have you checked the setting infinite flight connect is on?

Yes Enable LiveFlight Connect is ticked

Try and assign the axis through the laptop

Make sure you put it in before you open the application

I read the manual and I have installed all the drivers and had a update checker or whatever it’s called and there was no updates but I have installed the drivers and it said T-Flight HOTAS 4 is ready to use

Yea I have done that already, nothing