Joystick Issue

Hello everyone in the community,

Recently I have gotten a joystick for the wonderful game Infinite Flight. I have two issues. One, when applying my throttle to full on my joystick, the game only applies 50% thrust. The other issue is when my joystick is straight, IF has the yoke completely turned.

A few screenshots:

53 AM

Again, this is with my throttle fully up, and joystick still.

My attempts:

-Re-Installing Infinite Flight Live Connect.
-Different wifi network.
-Resetting axis on live flight connect and Infinite Flight
-Making sure Infinite Flight Connect is enabled

My devices:

-Thrustmaster T-Flight Hotas X Flight Stick Controller With Usb
-iPhone 6s 10.3.3
-Mac OSX
-Usb plug

If you need anymore info I’ll gladly give it.

Thanks for your help,

Issues with LiveFlight should be sent to support@liveflight.com

Thank you for using the correct support request format :).

Emailed, and yea, tried to use the right format.

This topic is ok to stay open, as others might benefit from the solution in the future. And the solution isn’t always sending a email.

12 Likes

Are you sure the sensitivity for your throttle is at 100%? If not all the way up will be whatever percentage you set it too.

All the way up @Kevin_Potthast

Hmm, not sure what to do then.

Very confusing, I know.

1 Like

A problem that always gets me is that the joystick actually isn’t plugged in - so pull it out and push it in and make sure it’s fully in there

1 Like

Also, have you tried slowly bringing the throttle to full? Becuase I find If it’s in one movement it sometimes doesn’t work

1 Like

For the first post, I it’s plugged in. I’ll try the 2nd.

Nope, didn’t work. Thanks for the help though.

1 Like

Ok, so the issue was that Gamepad mode was on. This is easily fixed by:

  1. Click the live flight connect button the on the top left of you screen, should look like this:44 AM

  2. If Gamepad mode has a check, click it. It should look like this afterwards: 53 AM.

Hope this helps folks.

3 Likes