Joystick for iOS

Hi guys,

Just a short question please, I couldn’t find this problem on the forum:

I’m trying to connect a joystick with liveflightconnect to the iOS tablet but it seems like I cannot make it work. When I go to the game settings to set the controls, tap to the roll, pitch or yaw, it doesn’t take any of the commands from the joystick. However, if I click the available devices, it’s showing me that the joystick is connected.

  • I’m using the same wifi on the laptop and the tablet
  • I have enabled the infinite flight connect in general settings
  • The joystick is Logitech Extreme 3d pro (connected to the usb and it’s working).

But still, if I’m trying to set the controls for the joystick, no response. Should be a problem from the liveflightconnect app? Or do I need to do something extra?

Please, any ideas? Anyone had this issue before? Thank you!

Hi, please note that LiveFlight Connect is no longer officially supported.

Have you tried restoring default controls and reconnecting? Is your autopilot on accidentally?

How do users use there joysticks without live flight?

Yes, I tried. No effect.
And no autopilot activated.

@preston what do you mean?

Have you tried to tab on (Use Networked Joystick)?!

Yes, and nothing…

Problem solved. Firewall or antivirus off and it’s working.

Thank you for your time!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.