Joystick connecting but not working

Can anyone please help me with my joystick, it says its connected, but not actually working on infinte flight?

Anyone who can help please contact me. I have a logitech Extreme 3D Pro

1 Like

Check out this topic:

1 Like

I’ve done it all right, but when I go to move the joystick and setup the pitch, roll etc it doesnt show the joystick is moving

I mainly need help on the axes and stuff that’s what’s not working

First: Are you using LiveFlight Connect (iOS) or plugging the joystick in directly (Android)?
Second: Are you assigning axes or just plugging and playing?

I’m using IOS, I’m plugging it into my macbook air, its connected but the axes are the problem

Two more questions: Has your joystick ever connected before? You have clicked “restored defaults” and then reassigned axes?

Check this thread for more support:

If it still doesn’t work, then there’s either a problem with the connection (where the program picks up the app, but can’t get inputs through over the network) or there’s something wrong with the program itself.

Here’s the support website for LiveFlight Connect as well.

Have you clicked on “Use Networked Joystick” in the controls tab? It should be to the right of “Setup Tutorial”.
Also, do you see all parameters working in “expand” on the liveflightapp?

1 Like

No I don’t see anything working 15641575436512555031846429483862 15641575774212697703713000610425

The joystick is connected

The joystick isn’t connected. It might be your cable?

Hey! I literally also had that exact same problem. I had to leave my flight and restart IF. Im still trouble shooting and have also posted a topic regarding this issue.

I’m not sure if it could be an issue regarding IF or LFC. I tried restarting my iMAC and it still didn’t work.

I’ve had problems with the this joystick in the past of it not being recognized on computers so it might be the joystick itself for me?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.